Start a new topic

Beorg SCHEDULED format incorrectly displays in Emacs Org agenda


When I add a scheduled task with a start and end time, Beorg formats it as:

SCHEDULED: <2024-05-03 Fri 17:00>--<2024-05-03 Fri 18:00>

Whereas when I schedule a task in Emacs, it's formatted as:

SCHEDULED: <2024-05-03 Fri 17:00-18:00>

Both of these appear in the agenda, but Beorg's format creates a duplicate entry like:


Whereas Emacs' entry displays as I would expect it to:


This is a little time-consuming to have to manually edit Beorg's entry in Emacs so it appears in the agenda as a single-line entry. It seems impossible to change this behavior in Beorg as when I manually edit SCHEDULED to be consistent with what Emacs expects, Beorg changes it back when I save the task.

I'm assuming this is a bug, is it not? Are there any plans to change this behavior, or is there a workaround to achieve consistency between Emacs and Beorg? So:

  • I don't have to spend time editing SCHEDULED in Emacs.
  • My agenda view isn't crowded by duplicate and incomplete entries that aren't needed.
  • Or so Emacs will operate similar to Beorg in this regard. (Maybe my least preferred option as I have a TON of tasks in Org.)
I write "crowded" because I have a lot in my agenda view and screen real estate is at a premium (laptop display), and "incomplete" because the duplicate entry doesn't contain the time range, it only shows the start time.

Any recommendations would be appreciated. 

This is something I need to resolve. I'll give this a bump up the priority list.

An update on this - I have a fix in place in the code. Once I've done some more testing will be part of the next update.

Login or Signup to post a comment