Start a new topic

Choose Folder Sync Renaming My .txt File

Sorry to be a PITA with a second post in this forum category.

Now that I have my .txt file syncing through my desired folder location under the "Choose Folder" method, it appears that when I edit the file in beorg, it's renaming the file by appending a "(1)" at the end. In my case, it's renaming my "todo.txt" to "todo(1).txt".

I tested by copying and pasting the same file in to my beorg iCloud folder, and the name-change is not happening in there, it just seems to be when I have the "Choose Folder" method selected.

Again, I'd really appreciate some guidance/looking in to this. Happy to debug etc if you can give instructions on how I'd go about that.

Many thanks.

  • Are you getting any messages from beorg about a conflict?
  • Are you syncing with a location in iCloud, a local folder on your device, another app (and if so which one)?

beorg itself won't be adding the (1), it looks as though something else is doing that. Hopefully with a little more information I can reproduce this and see how I can improve things.

• No I'm not getting any conflict messages

• Syncing with a folder in iCloud (outside of the beorg folder)

I've tested in in various ways now, and still having the same issue occur. The last thing I tried was to create a blank folder, and add a blank "todo.txt" file inside. Nothing else in the folder (to avoid conflicts). I then select this folder in beorg and it initially syncs normally, but as soon as I add any todo entry, and click the sync cloud icon, it then renames the file to "todo(1).txt. I have tried to then manually rename it back, but again when I re-add another todo entry it changes back again.

To test further, I have tried with a variety of unique file names, but all return the same results.

Thank you the extra information. I'll need to look into this further.


I wanted to provide some more info here, since I've tested a little further. Its seems that my issue with the file getting renamed is only happening with iCloud for Windows. When checking the file on both my Mac and via, the file does not appear to be getting renamed.

I'm not too sure what is causing this to happen, as it my file is not getting renamed if I use the "beorg" folder sync option, but this may be an issue that is isolated in the Windows environment.

I'll keep trying to find a solution on my end, and update here if I do, but didn't want to waste your time trying to find the problem if you don't have a Windows machine.



Thanks for the update Tom. I reviewed some of the lower level code and couldn't see why the files would be renamed in this fashion. I probably have a Windows VM around somewhere but its not something I fire up very regularly!

A quick search shows a recent forum post from a few weeks ago with someone experiencing a similar issue on Windows. Maybe this is a recent bug in iCloud for Windows and hopefully Apple will soon fix.

Login or Signup to post a comment