Start a new topic

Slow input from external keyboard in Beorg


I am mostly using my iPad Air 2 with a logitech Keys-to-go external keyboard. When I use Beorg and input text into any field I get really slow response. It takes 0.5-1-5 seconds between pressing a key on the keyboard until it shows up on the screen. This issue has been consistent through IOS 13 and 14, it is the same issue with a apple magic keyboard that I tried with and this is not an issue in other apps. I would love for this issue to be solved so that I can actually take notes in Beorg when I only have my ipad with me. Any other information I can give to help solve this issue?

If you are able to create a video demonstrating the slow text entry that would be great. If it could show entry into a variety of fields.

Have you created an file to customise beorg? If so have you changed any of the keyboard shortcuts or the text editor commands?

I am sorry but not had any opportunity to make a video yet but I will try for that in the coming weekend. Will be shaky iPhone video of my iPad while typing with one hand so be warned. 

And no, I have not changed anything through, I have only changed settings available in the graphical settings screen in the app. 

I have noticed this issue as well, I take a lot of notes on my iPad Pro with Smart Keyboard (iPad7,3; model A1701, iOS 14.3).  Attached is a video.  I also do not customize with


Thank you posting this video. I will look into this again and try to think what might be causing this slowdown. I don't have an iPad Pro with Smart Keyboard to reproduce this on, however do have a number of other Bluetooth keyboards. I'm guessing you never have any issues with any other apps?

No, I have also taken extensive notes in OneNote without keyboard lag, and use this device for a significant amount of text entry in many other apps.  Beorg is the only one where I see this behavior.  Sorry!  

I have managed to reproduce this and am working through fixing this bug, which I hope to finish next week. If you'd like to help test the fix let me know and I'll send you a TestFlight invite once I've got everything working.

(This bug was caused by how beorg handles keyboard shortcuts, and how those shortcuts can be customised via Scheme. I'm having a little problem not breaking some keyboard shortcuts with my fix, but I'm sure I can resolve that!)

There is a TestFlight build which should improve typing speed quite significantly. You should have received a TestFlight invite, please let me know if this new build helps your issue.

There may be some delay, but I have not received the TestFlight invite yet.

I've told TestFlight to resend the invite. I have sent the invite to the email address you used on the forum. If there is a different one to use please email me directly at

OK, that time I got it! Beta is installed, I will let you know! Thank you!!

YES!  This fixes the issue.  Thank you SO much, this will make my notetaking so much easier!

Login or Signup to post a comment