Start a new topic

x-callback-url title and name parameters ignored when template specified?

I'm trying to build a Shortcut using a beorg://x-callback-url/capture scheme. (as per various how-to docs)


Whenever I supply a template parameter and don't also pass edit=true the shortcut fails with "The operation couldn't be completed. (InterchangeCallbackErrorDomain error 0.)".


Using edit=true I can see that whatever I pass in title and notes parameters is ignored and both are blank (which may be the cause of the error?).


I can reproduce by creating a default template called Test and then creating a single-action Shortcut which invokes beorg://x-callback-url/capture?template=Test&title=Anything&notes=Anything.


Am I missing something?


beorg 3.4.0



If you can share a screenshot of the Shortcut (or the Shortcut itself) that would help me look into this. Theoretically you should be able to do what your attempting :)

Two screenshots: shortcut and template. Trivial shortcut just for reproducing. This shortcut produces the error when run.


Adding edit=true and populating more of the template allows you to see that the template content is being populated by title and notes aren't.

I'm able to reproduce your issue when edit=true is included, it is working without that. I'll take a look - however will likely now be in the New Year as finishing for Christmas in a few hours. I'll look at answer any support questions over the Christmas period but anything else will be kept until after New Years day.

No worries:) Have a great Christmas! (I’ll post again if my experiments reveal anything interesting but feel free to ignore.)
It seems that edit=true is not helping with the diagnosis here. It blanks title and notes regardless of whether template is specified. But requests without the template parameter do not fail. So while edit=true does allow me to see that the template parameter is being picked up prior the to error (as tags from the template are applied), the title and notes blanking seems to be orthogonal to the error.
Got it. The error only occurs when the Save To field is left as Use Quick Capture File. If I specify the file manually everything suddenly works.
In case it is relevant, my quick capture file is called “refile”, not left as the default (inbox?).

BTW: I had the same problem - even from the beginning I did not use Quick Capture File - so I think this is not the root cause.


Specifying a wrong template name will result in exactly the issue/problem from Greg.

So I think it might be that just a wrong template name or not finding the template is the issue.


I renamed my template from "File Web Page" to "webpage" and it worked - might also did have some newline before.


@Matthew: Could a better error message like "Could not find template" help here?

I'll look into how an error message could be introduced to help here. It might be in your case that you needed to URL encode the template name due to the spaces.

Login or Signup to post a comment