Start a new topic

Repeating task doesn't keep the TODO state

I use number of repeating task for regular actions I need to keep track of. Following GTD methodology my TODO states are not a sequence but denote different contexts. When marking a repeating task done the new instance receives the first of my TODO states not the one it had before. In Emacs I use the RETURN_TO_STATE Property to achieve this but it seems to be ignored in beorg. Am I missing a setting or is this a bug? Thanks for the otherwise awesome app!

Thank you for mentioning this. That property isn't currently supported by beorg. Could you send me the snippet of your Emacs configuration so I can look into this and see how beorg could support this as an option.

Here is a simple test file. In Emacs if I mark task1 as done it 's updated for tomorrow with the same TODO state. BeOrg acts like task2 which is updated with the first TODO state. I'm looking to use BeOrg like Emacs behaves for task1 at least if REPEAT_TO_STATE is set.

Thanks for the fast response by the way!

(333 Bytes)

Thanks for providing this example. Support for REPEAT_TO_STATE will be in the next beorg update.

1 person likes this

Thanks a lot for considering it!

Works perfectly! Thanks a lot for the fast implementation

Glad to hear it is working for you! 

Login or Signup to post a comment