Start a new topic

Search with Chinese character can't find result


How to reproduce:

  1. My org file on Mac is stored in UTF-8 format (by default). 
  2. Enter a title in inbox.org "Emacs 简介" on MAC.
  3. Sync with icloud.
  4. In Beorg "TODO" tab, perform search, if I search "Emacs", it will show the entry. But, if I search "简介", it shows nothing.




1 person has this problem

Thank you for reporting this problem, I will investigate.

I've realised the issue is not the characters but the number of characters entered. beorg only performs the search is 3 or more characters are entered. This minimum length isn't helpful for languages such as Chinese. What I'm going to do is add a setting so a user can change this. The reason for the setting is performance when searching using the UI. You'll see this new setting in the next update.


1 person likes this

Seems that there is still no such option in version 2.15.0(129)

This is a setting that needs to be added to your init.org - for example

(set! filter-min-chars 2)


If you aren't familiar with using an init.org for advanced configuration of beorg please review https://beorg.app/learning/excluding-tasks-from-specific-files-for-the-agenda-and-todo-lists/

Login or Signup to post a comment